Software Configuration Guide, Cisco IOS Release 15.2(2)E (Catalyst 2960, 2960-S, 2960-SF and 2960-Plus Switches) - Configuring VLAN Trunks [Cisco Catalyst 2960 Series Switches] (2024)

Table of Contents
Finding Feature Information Prerequisites for VLAN Trunks Restrictions for VLAN Trunks Trunking Overview Trunking Modes Layer 2 Interface Modes Allowed VLANs on a Trunk Load Sharing on Trunk Ports Network Load Sharing Using STP Priorities Network Load Sharing Using STP Path Cost Default Layer 2 Ethernet Interface VLAN Configuration Configuring a Trunk Port SUMMARY STEPS DETAILED STEPS Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Defining the Allowed VLANs on a Trunk SUMMARY STEPS DETAILED STEPS Example: Example: Example: Example: Example: Example: Example: Example: Example: Changing the Pruning-Eligible List SUMMARY STEPS DETAILED STEPS Example: Example: Example: Example: Example: Example: Configuring the Native VLAN for Untagged Traffic SUMMARY STEPS DETAILED STEPS Example: Example: Example: Example: Example: Example: Example: Configuring Load Sharing Using STP Port Priorities SUMMARY STEPS DETAILED STEPS Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Configuring Load Sharing Using STP Path Cost SUMMARY STEPS DETAILED STEPS Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Example: Configuring a Trunk Port Example: Removing a VLAN from a Port Where to Go Next Additional References Related Documents Standards and RFCs MIBs Technical Assistance References

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for VLAN Trunks

The IEEE 802.1Q trunks impose these limitations on the trunking strategy for a network:

  • In a network of Cisco switches connected through IEEE 802.1Q trunks, the switches maintain one spanning-tree instance for each VLAN allowed on the trunks. Non-Cisco devices might support one spanning-tree instance for all VLANs.

    When you connect a Cisco switch to a non-Cisco device through an IEEE 802.1Q trunk, the Cisco switch combines the spanning-tree instance of the VLAN of the trunk with the spanning-tree instance of the non-Cisco IEEE 802.1Q switch. However, spanning-tree information for each VLAN is maintained by Cisco switches separated by a cloud of non-Cisco IEEE 802.1Q switches. The non-Cisco IEEE 802.1Q cloud separating the Cisco switches is treated as a single trunk link between the switches.

  • Make sure the native VLAN for an IEEE 802.1Q trunk is the same on both ends of the trunk link. If the native VLAN on one end of the trunk is different from the native VLAN on the other end, spanning-tree loops might result.

  • Disabling spanning tree on the native VLAN of an IEEE 802.1Q trunk without disabling spanning tree on every VLAN in the network can potentially cause spanning-tree loops. We recommend that you leave spanning tree enabled on the native VLAN of an IEEE 802.1Q trunk or disable spanning tree on every VLAN in the network. Make sure your network is loop-free before disabling spanning tree.

Restrictions for VLAN Trunks

The following are restrictions for VLAN trunks:

Information about VLAN Trunks

Trunking Overview

A trunk is a point-to-point link between one or more Ethernet switch interfaces and another networking device such as a router or a switch. Ethernet trunks carry the traffic of multiple VLANs over a single link, and you can extend the VLANs across an entire network.

Software Configuration Guide, Cisco IOS Release 15.2(2)E (Catalyst 2960, 2960-S, 2960-SF and 2960-Plus Switches) - Configuring VLAN Trunks [Cisco Catalyst 2960 Series Switches] (1)
Note

You can configure a trunk on a single Ethernet interface or on an EtherChannel bundle.

Trunking Modes

Ethernet trunk interfaces support different trunking modes. You can set an interface as trunking or nontrunking or to negotiate trunking with the neighboring interface. To autonegotiate trunking, the interfaces must be in the same VTP domain.

You can configure a trunk on a single Ethernet interface or on an EtherChannel bundle.

Trunk negotiation is managed by the Dynamic Trunking Protocol (DTP), which is a Point-to-Point Protocol (PPP). However, some internetworking devices might forward DTP frames improperly, which could cause misconfigurations.

To avoid this, you should configure interfaces connected to devices that do not support DTP to not forward DTP frames, that is, to turn off DTP.

  • If you do not intend to trunk across those links, use the switchport mode access interface configuration command to disable trunking.

  • To enable trunking to a device that does not support DTP, use the switchport mode trunk and switchport nonegotiate interface configuration commands to cause the interface to become a trunk but to not generate DTP frames.

You can also specify on DTP interfaces whether the trunk uses IEEE 802.1Q encapsulation or if the encapsulation type is autonegotiated. The DTP supports autonegotiation of IEEE 802.1Q trunks.

Layer 2 Interface Modes

Table 1. Layer 2 Interface Modes

Mode

Function

switchport mode access

Puts the interface (access port) into permanent nontrunking mode and negotiates to convert the link into a nontrunk link. The interface becomes a nontrunk interface regardless of whether or not the neighboring interface is a trunk interface.

switchport mode dynamic auto

Makes the interface able to convert the link to a trunk link. The interface becomes a trunk interface if the neighboring interface is set to trunk or desirable mode. The default switchport mode for all Ethernet interfaces is dynamic auto .

switchport mode dynamic desirable

Makes the interface actively attempt to convert the link to a trunk link. The interface becomes a trunk interface if the neighboring interface is set to trunk , desirable , or auto mode.

switchport mode trunk

Puts the interface into permanent trunking mode and negotiates to convert the neighboring link into a trunk link. The interface becomes a trunk interface even if the neighboring interface is not a trunk interface.

switchport nonegotiate

Prevents the interface from generating DTP frames. You can use this command only when the interface switchport mode is access or trunk . You must manually configure the neighboring interface as a trunk interface to establish a trunk link.

Allowed VLANs on a Trunk

By default, a trunk port sends traffic to and receives traffic from all VLANs. All VLAN IDs, 1 to 4094, are allowed on each trunk. However, you can remove VLANs from the allowed list, preventing traffic from those VLANs from passing over the trunk.

VLAN 1 is the default VLAN on all trunk ports in all Cisco switches, and it has previously been a requirement that VLAN 1 always be enabled on every trunk link. You can use the VLAN 1 minimization feature to disable VLAN 1 on any individual VLAN trunk link so that no user traffic (including spanning-tree advertisem*nts) is sent or received on VLAN 1.

To reduce the risk of spanning-tree loops or storms, you can disable VLAN 1 on any individual VLAN trunk port by removing VLAN 1 from the allowed list. When you remove VLAN 1 from a trunk port, the interface continues to send and receive management traffic, for example, Cisco Discovery Protocol (CDP), Port Aggregation Protocol (PAgP), Link Aggregation Control Protocol (LACP), DTP, and VTP in VLAN 1.

If a trunk port with VLAN 1 disabled is converted to a nontrunk port, it is added to the access VLAN. If the access VLAN is set to 1, the port will be added to VLAN 1, regardless of the switchport trunk allowed setting. The same is true for any VLAN that has been disabled on the port.

A trunk port can become a member of a VLAN if the VLAN is enabled, if VTP knows of the VLAN, and if the VLAN is in the allowed list for the port. When VTP detects a newly enabled VLAN and the VLAN is in the allowed list for a trunk port, the trunk port automatically becomes a member of the enabled VLAN. When VTP detects a new VLAN and the VLAN is not in the allowed list for a trunk port, the trunk port does not become a member of the new VLAN.

Load Sharing on Trunk Ports

Load sharing divides the bandwidth supplied by parallel trunks connecting switches. To avoid loops, STP normally blocks all but one parallel link between switches. Using load sharing, you divide the traffic between the links according to which VLAN the traffic belongs.

You configure load sharing on trunk ports by using STP port priorities or STP path costs. For load sharing using STP port priorities, both load-sharing links must be connected to the same switch. For load sharing using STP path costs, each load-sharing link can be connected to the same switch or to two different switches.

Network Load Sharing Using STP Priorities

When two ports on the same switch form a loop, the switch uses the STP port priority to decide which port is enabled and which port is in a blocking state. You can set the priorities on a parallel trunk port so that the port carries all the traffic for a given VLAN. The trunk port with the higher priority (lower values) for a VLAN is forwarding traffic for that VLAN. The trunk port with the lower priority (higher values) for the same VLAN remains in a blocking state for that VLAN. One trunk port sends or receives all traffic for the VLAN.

Network Load Sharing Using STP Path Cost

You can configure parallel trunks to share VLAN traffic by setting different path costs on a trunk and associating the path costs with different sets of VLANs, blocking different ports for different VLANs. The VLANs keep the traffic separate and maintain redundancy in the event of a lost link.

Default Layer 2 Ethernet Interface VLAN Configuration

The following table shows the default Layer 2 Ethernet interface VLAN configuration.

Table 2. Default Layer 2 Ethernet Interface VLAN Configuration

Feature

Default Setting

Interface mode

switchport mode dynamic auto

Allowed VLAN range

VLANs 1 to 4094

VLAN range eligible for pruning

VLANs 2 to 1001

Default VLAN (for access ports)

VLAN 1

Native VLAN (for IEEE 802.1Q trunks)

VLAN 1

How to Configure VLAN Trunks

Configuring an Ethernet Interface as a Trunk Port

Configuring a Trunk Port

Because trunk ports send and receive VTP advertisem*nts, to use VTP you must ensure that at least one trunk port is configured on the switch and that this trunk port is connected to the trunk port of a second switch. Otherwise, the switch cannot receive any VTP advertisem*nts.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface interface-id
  4. switchport mode {dynamic {auto | desirable } | trunk }
  5. switchport access vlan vlan-id
  6. switchport trunk native vlan vlan-id
  7. end
  8. show interfaces interface-id switchport
  9. show interfaces interface-id trunk
  10. copy running-config startup-config

DETAILED STEPS

Command or Action Purpose
Step1

enable

Example:

Switch> enable

Enables privileged EXEC mode. Enter your password if prompted.

Step2

configure terminal

Example:

Switch# configure terminal

Enters the global configuration mode.

Step3

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/2

Specifies the port to be configured for trunking, and enters interface configuration mode.

Step4

switchport mode {dynamic {auto | desirable } | trunk }

Example:

Switch(config-if)# switchport mode dynamic desirable

Configures the interface as a Layer 2 trunk (required only if the interface is a Layer 2 access port or tunnel port or to specify the trunking mode).

  • dynamic auto —Sets the interface to a trunk link if the neighboring interface is set to trunk or desirable mode. This is the default.

  • dynamic desirable —Sets the interface to a trunk link if the neighboring interface is set to trunk, desirable, or auto mode.

  • trunk —Sets the interface in permanent trunking mode and negotiate to convert the link to a trunk link even if the neighboring interface is not a trunk interface.

Step5

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 200

(Optional) Specifies the default VLAN, which is used if the interface stops trunking.

Step6

switchport trunk native vlan vlan-id

Example:

Switch(config-if)# switchport trunk native vlan 200

Specifies the native VLAN for IEEE 802.1Q trunks.

Step7

end

Example:

Switch(config)# end

Returns to privileged EXEC mode.

Step8

show interfaces interface-id switchport

Example:

Switch# show interfaces gigabitethernet1/0/2 switchport

Displays the switch port configuration of the interface in the Administrative Mode and the Administrative Trunking Encapsulation fields of the display.

Step9

show interfaces interface-id trunk

Example:

Switch# show interfaces gigabitethernet1/0/2 trunk

Displays the trunk configuration of the interface.

Step10

copy running-config startup-config

Example:

Switch# copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Defining the Allowed VLANs on a Trunk

VLAN 1 is the default VLAN on all trunk ports in all Cisco switches, and it has previously been a requirement that VLAN 1 always be enabled on every trunk link. You can use the VLAN 1 minimization feature to disable VLAN 1 on any individual VLAN trunk link so that no user traffic (including spanning-tree advertisem*nts) is sent or received on VLAN 1.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface interface-id
  4. switchport mode trunk
  5. switchport trunk allowed vlan {add | all | except | remove } vlan-list
  6. switchport trunk allowed vlan { word | add | all | except | none | remove } vlan-list
  7. end
  8. show interfaces interface-id switchport
  9. copy running-config startup-config

DETAILED STEPS

Command or Action Purpose
Step1

enable

Example:

Switch> enable

Enables privileged EXEC mode. Enter your password if prompted.

Step2

configure terminal

Example:

Switch# configure terminal

Enters the global configuration mode.

Step3

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/1

Specifies the port to be configured, and enters interface configuration mode.

Step4

switchport mode trunk

Example:

Switch(config-if)# switchport mode trunk

Configures the interface as a VLAN trunk port.

Step5

switchport trunk allowed vlan {add | all | except | remove } vlan-list

Example:

Switch(config-if)# switchport trunk allowed vlan remove 2

(Optional) Configures the list of VLANs allowed on the trunk.

The vlan-list parameter is either a single VLAN number from 1 to 4094 or a range of VLANs described by two VLAN numbers, the lower one first, separated by a hyphen. Do not enter any spaces between comma-separated VLAN parameters or in hyphen-specified ranges.

All VLANs are allowed by default.

Step6

switchport trunk allowed vlan { word | add | all | except | none | remove } vlan-list

Example:

Switch(config-if)# switchport trunk allowed vlan remove 2

(Optional) Configures the list of VLANs allowed on the trunk.

The vlan-list parameter is either a single VLAN number from 1 to 4094 or a range of VLANs described by two VLAN numbers, the lower one first, separated by a hyphen. Do not enter any spaces between comma-separated VLAN parameters or in hyphen-specified ranges.

All VLANs are allowed by default.

Step7

end

Example:

Switch(config)# end

Returns to privileged EXEC mode.

Step8

show interfaces interface-id switchport

Example:

Switch# show interfaces gigabitethernet1/0/1 switchport

Verifies your entries in the Trunking VLANs Enabled field of the display.

Step9

copy running-config startup-config

Example:

Switch# copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Changing the Pruning-Eligible List

The pruning-eligible list applies only to trunk ports. Each trunk port has its own eligibility list. VTP pruning must be enabled for this procedure to take effect.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface interface-id
  4. switchport trunk pruning vlan {add | except | none | remove } vlan-list [,vlan [,vlan [,,,]]
  5. end
  6. show interfaces interface-id switchport
  7. copy running-config startup-config

DETAILED STEPS

Command or Action Purpose
Step1

enable

Example:

Switch> enable

Enables privileged EXEC mode. Enter your password if prompted.

Step2

configure terminal

Example:

Switch# configure terminal

Enters the global configuration mode.

Step3

interface interface-id

Example:

Switch(config)# interface gigabitethernet2/0/1

Selects the trunk port for which VLANs should be pruned, and enters interface configuration mode.

Step4

switchport trunk pruning vlan {add | except | none | remove } vlan-list [,vlan [,vlan [,,,]]

Configures the list of VLANs allowed to be pruned from the trunk.

For explanations about using the add , except , none , and remove keywords, see the command reference for this release.

Separate non-consecutive VLAN IDs with a comma and no spaces; use a hyphen to designate a range of IDs. Valid IDs are 2 to 1001. Extended-range VLANs (VLAN IDs 1006 to 4094) cannot be pruned.

VLANs that are pruning-ineligible receive flooded traffic.

The default list of VLANs allowed to be pruned contains VLANs 2 to 1001.

Step5

end

Example:

Switch(config)# end

Returns to privileged EXEC mode.

Step6

show interfaces interface-id switchport

Example:

Switch# show interfaces gigabitethernet2/0/1 switchport

Verifies your entries in the Pruning VLANs Enabled field of the display.

Step7

copy running-config startup-config

Example:

Switch# copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Configuring the Native VLAN for Untagged Traffic

A trunk port configured with IEEE 802.1Q tagging can receive both tagged and untagged traffic. By default, the switch forwards untagged traffic in the native VLAN configured for the port. The native VLAN is VLAN 1 by default.

The native VLAN can be assigned any VLAN ID.

If a packet has a VLAN ID that is the same as the outgoing port native VLAN ID, the packet is sent untagged; otherwise, the switch sends the packet with a tag.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface interface-id
  4. switchport trunk native vlan vlan-id
  5. end
  6. show interfaces interface-id switchport
  7. copy running-config startup-config

DETAILED STEPS

Command or Action Purpose
Step1

enable

Example:

Switch> enable

Enables privileged EXEC mode. Enter your password if prompted.

Step2

configure terminal

Example:

Switch# configure terminal

Enters the global configuration mode.

Step3

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/2

Defines the interface that is configured as the IEEE 802.1Q trunk, and enters interface configuration mode.

Step4

switchport trunk native vlan vlan-id

Example:

Switch(config-if)# switchport trunk native vlan 12

Configures the VLAN that is sending and receiving untagged traffic on the trunk port.

For vlan-id , the range is 1 to 4094.

Note

To return to the default native VLAN, VLAN 1, use the no switchport trunk native vlan interface configuration command.

Step5

end

Example:

Switch(config-if)# end

Returns to privileged EXEC mode.

Step6

show interfaces interface-id switchport

Example:

Switch# show interfaces gigabitethernet1/0/2 switchport

Verifies your entries in the Trunking Native Mode VLAN field.

Step7

copy running-config startup-config

Example:

Switch# copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Configuring Trunk Ports for Load Sharing

Configuring Load Sharing Using STP Port Priorities

These steps describe how to configure a network with load sharing using STP port priorities.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. vtp domain domain-name
  4. vtp mode server
  5. end
  6. show vtp status
  7. show vlan
  8. configure terminal
  9. interface interface-id
  10. switchport mode trunk
  11. end
  12. show interfaces interface-id switchport
  13. Repeat the above steps on Switch A for a second port in the switch.
  14. Repeat the above steps on Switch B to configure the trunk ports that connect to the trunk ports configured on Switch A.
  15. show vlan
  16. configure terminal
  17. interface interface-id
  18. spanning-tree vlan vlan-range port-priority priority-value
  19. exit
  20. interface interface-id
  21. spanning-tree vlan vlan-range port-priority priority-value
  22. end
  23. show running-config
  24. copy running-config startup-config

DETAILED STEPS

Command or Action Purpose
Step1

enable

Example:

Switch> enable

Enables privileged EXEC mode. Enter your password if prompted.

Step2

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode on SwitchA.

Step3

vtp domain domain-name

Example:

Switch(config)# vtp domain workdomain

Configures a VTP administrative domain.

The domain name can be 1 to 32 characters.

Step4

vtp mode server

Example:

Switch(config)# vtp mode server

Configures Switch A as the VTP server.

Step5

end

Example:

Switch(config)# end

Returns to privileged EXEC mode.

Step6

show vtp status

Example:

Switch# show vtp status

Verifies the VTP configuration on both Switch A and Switch B.

In the display, check the VTP Operating Mode and the VTP Domain Name fields.

Step7

show vlan

Example:

Switch# show vlan

Verifies that the VLANs exist in the database on Switch A.

Step8

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode.

Step9

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/1

Defines the interface to be configured as a trunk, and enters interface configuration mode.

Step10

switchport mode trunk

Example:

Switch(config-if)# switchport mode trunk

Configures the port as a trunk port.

Step11

end

Example:

Switch(config-if)# end

Returns to privileged EXEC mode.

Step12

show interfaces interface-id switchport

Example:

Switch# show interfaces gigabitethernet1/0/1 switchport

Verifies the VLAN configuration.

Step13

Repeat the above steps on Switch A for a second port in the switch.

Step14

Repeat the above steps on Switch B to configure the trunk ports that connect to the trunk ports configured on Switch A.

Step15

show vlan

Example:

Switch# show vlan

When the trunk links come up, VTP passes the VTP and VLAN information to Switch B. This command verifies that Switch B has learned the VLAN configuration.

Step16

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode on Switch A.

Step17

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/1

Defines the interface to set the STP port priority, and enters interface configuration mode.

Step18

spanning-tree vlan vlan-range port-priority priority-value

Example:

Switch(config-if)# spanning-tree vlan 8-10 port-priority 16

Assigns the port priority for the VLAN range specified. Enter a port priority value from 0 to 240. Port priority values increment by 16.

Step19

exit

Example:

Switch(config-if)# exit

Returns to global configuration mode.

Step20

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/2

Defines the interface to set the STP port priority, and enters interface configuration mode.

Step21

spanning-tree vlan vlan-range port-priority priority-value

Example:

Switch(config-if)# spanning-tree vlan 3-6 port-priority 16

Assigns the port priority for the VLAN range specified. Enter a port priority value from 0 to 240. Port priority values increment by 16.

Step22

end

Example:

Switch(config-if)# end

Returns to privileged EXEC mode.

Step23

show running-config

Example:

Switch# show running-config

Verifies your entries.

Step24

copy running-config startup-config

Example:

Switch# copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Configuring Load Sharing Using STP Path Cost

These steps describe how to configure a network with load sharing using STP path costs.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface interface-id
  4. switchport mode trunk
  5. exit
  6. Repeat Steps 2 through 4 on a second interface in Switch A .
  7. end
  8. show running-config
  9. show vlan
  10. configure terminal
  11. interface interface-id
  12. spanning-tree vlan vlan-range cost cost-value
  13. end
  14. Repeat Steps 9 through 13 on the other configured trunk interface on Switch A, and set the spanning-tree path cost to 30 for VLANs 8, 9, and 10.
  15. exit
  16. show running-config
  17. copy running-config startup-config

DETAILED STEPS

Command or Action Purpose
Step1

enable

Example:

Switch> enable

Enables privileged EXEC mode. Enter your password if prompted.

Step2

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode on Switch A.

Step3

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/1

Defines the interface to be configured as a trunk, and enters interface configuration mode.

Step4

switchport mode trunk

Example:

Switch(config-if)# switchport mode trunk

Configures the port as a trunk port.

Step5

exit

Example:

Switch(config-if)# exit

Returns to global configuration mode.

Step6

Repeat Steps 2 through 4 on a second interface in Switch A .

Step7

end

Example:

Switch(config)# end

Returns to privileged EXEC mode.

Step8

show running-config

Example:

Switch# show running-config

Verifies your entries. In the display, make sure that the interfaces are configured as trunk ports.

Step9

show vlan

Example:

Switch# show vlan

When the trunk links come up, Switch A receives the VTP information from the other switches. This command verifies that Switch A has learned the VLAN configuration.

Step10

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode.

Step11

interface interface-id

Example:

Switch(config)# interface gigabitethernet1/0/1

Defines the interface on which to set the STP cost, and enters interface configuration mode.

Step12

spanning-tree vlan vlan-range cost cost-value

Example:

Switch(config-if)# spanning-tree vlan 2-4 cost 30

Sets the spanning-tree path cost to 30 for VLANs 2 through 4.

Step13

end

Example:

Switch(config-if)# end

Returns to global configuration mode.

Step14

Repeat Steps 9 through 13 on the other configured trunk interface on Switch A, and set the spanning-tree path cost to 30 for VLANs 8, 9, and 10.

Step15

exit

Example:

Switch(config)# exit

Returns to privileged EXEC mode.

Step16

show running-config

Example:

Switch# show running-config

Verifies your entries. In the display, verify that the path costs are set correctly for both trunk interfaces.

Step17

copy running-config startup-config

Example:

Switch# copy running-config startup-config

(Optional) Saves your entries in the configuration file.

Configuration Examples for VLAN Trunking

Example: Configuring a Trunk Port

The following example shows how to configure a port as an IEEE 802.1Q trunk. The example assumes that the neighbor interface is configured to support IEEE 802.1Q trunking.

Switch# configure terminalEnter configuration commands, one per line. End with CNTL/Z.Switch(config)# interface gigabitethernet1/0/2Switch(config-if)# switchport mode dynamic desirableSwitch(config-if)# end

Example: Removing a VLAN from a Port

This example shows how to remove VLAN 2 from the allowed VLAN list on a port:

Switch(config)# interface gigabitethernet1/0/1Switch(config-if)# switchport trunk allowed vlan remove 2Switch(config-if)# end

Where to Go Next

After configuring VLAN trunks, you can configure the following:

  • VLANs

Additional References

Related Documents

Related Topic Document Title

CLI commands

VLAN Command Reference (Catalyst 2960, 2960-S, 2960-SF and 2960-Plus Switches)

Standards and RFCs

Standard/RFC Title

RFC 1573

Evolution of the Interfaces Group of MIB-II

RFC 1757

Remote Network Monitoring Management

RFC 2021

SNMPv2 Management Information Base for the Transmission Control Protocol using SMIv2

MIBs

MIB MIBs Link

All supported MIBs for this release.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

Technical Assistance

Description Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/support

Software Configuration Guide, Cisco IOS Release 15.2(2)E (Catalyst 2960, 2960-S, 2960-SF and 2960-Plus Switches)  - Configuring VLAN Trunks [Cisco Catalyst 2960 Series Switches] (2024)

References

Top Articles
Latest Posts
Article information

Author: Arline Emard IV

Last Updated:

Views: 6013

Rating: 4.1 / 5 (72 voted)

Reviews: 87% of readers found this page helpful

Author information

Name: Arline Emard IV

Birthday: 1996-07-10

Address: 8912 Hintz Shore, West Louie, AZ 69363-0747

Phone: +13454700762376

Job: Administration Technician

Hobby: Paintball, Horseback riding, Cycling, Running, Macrame, Playing musical instruments, Soapmaking

Introduction: My name is Arline Emard IV, I am a cheerful, gorgeous, colorful, joyous, excited, super, inquisitive person who loves writing and wants to share my knowledge and understanding with you.